请选择 进入手机版 | 继续访问电脑版

[视频教程] 传奇微信公众号开发:7.向服务端发送元宝物品

  [复制链接]
查看6228 | 回复87 | 2020-2-17 19:15:45 | 显示全部楼层 |阅读模式
易语言开发微信公众号传奇网关_第七课,主网关向服务端发送元宝,物品等物,传奇服务端和微信公众号对接视频教程说明。

传奇E语言开发微信公众号网关

传奇E语言开发微信公众号网关

第七课:主网关向服务端发送元宝,物品等物品
相关重要代码:
.如果真 (xml.取节点值文本 (“xml/Type”, ) = “关注礼包”)
    游戏路径 = xml.取节点值文本 (“xml/路径”, ) + “Mir200\Envir\QuestDiary\微信系统\关注礼包.txt”
    写到文件 (游戏路径, 读入文件 (游戏路径) + 到字节集 (#换行符 + xml.取节点值文本 (“xml/账号”, )))
    日志输出 (“分区[” + xml.取节点值文本 (“xml/名称”, ) + “]玩家[” + xml.取节点值文本 (“xml/账号”, ) + “]领取了关注礼包...”)
    返回 ()
.如果真结束
.如果真 (xml.取节点值文本 (“xml/Type”, ) = “游戏充值”)
    游戏路径 = xml.取节点值文本 (“xml/路径”, ) + “Mir200\Envir\QuestDiary\微信系统\元宝领取\”
    N1 = xml.取节点值文本 (“xml/数量”, )
    .判断循环首 (N < 取文本长度 (N1))
        .如果真 (取文本中间 (N1, 取文本长度 (N1) - N, 1) ≠ “0”)
            写到文件 (游戏路径 + 取文本中间 (N1, 取文本长度 (N1) - N, 1) + 零补位 + “.txt”, 到字节集 (xml.取节点值文本 (“xml/账号”, )) + 到字节集 (#换行符) + 到字节集 (读入文件 (游戏路径 + 取文本中间 (N1, 取文本长度 (N1) - N, 1) + 零补位 + “.txt”)))
        .如果真结束
        零补位 = 零补位 + “0”
        N = N + 1
        日志输出 (游戏路径 + 取文本中间 (N1, 取文本长度 (N1) - N, 1) + 零补位 + “.txt”)
    .判断循环尾 ()
    日志输出 (“分区[” + xml.取节点值文本 (“xml/名称”, ) + “]玩家[” + xml.取节点值文本 (“xml/账号”, ) + “]兑换了[” + xml.取节点值文本 (“xml/数量”, ) + “]元宝...”)
----------------------------------------------------
第八课:微信用户向服务端发送数据
源码附件第7课.rar (315.87 KB, 下载次数: 33, 售价: 200 金钱)

传奇服务端版本附件下载说明 1、传奇GM论坛(WWW.DIYGM.COM)提供大量传奇版本服务端免费下载。
2、本站发布的传奇版本服务端,补丁素材,工具教程,登录器等全部均测试通过。
3、本站传奇相关资源附件以研究交流为目的,商业用途造成的后果与本站无关。
4、《传奇版本库》部分优质资源需要使用论坛会员下载或者金币下载。
获取金币方法:1、金币充值  2、免费获得传奇GM论坛基地金币。
回复

使用道具 举报

kankai | 2020-2-18 12:46:54 | 显示全部楼层

找个师傅教教我架设私服。就4个朋友一起玩。。请师傅加我QQ77456764。谢谢。。。

回复

使用道具 举报

198256 | 2020-2-20 01:47:48 | 显示全部楼层
顶顶顶顶顶顶顶顶顶

回复

使用道具 举报

3588253 | 2020-2-20 12:25:02 | 显示全部楼层
RE: 传奇微信公众号开发:7.向服务端发送元宝物品 [修改]

回复

使用道具 举报

11qw22as | 2020-2-29 03:30:33 | 显示全部楼层
哦玉一颗积极坎坎坷坷坎坎坷坷

回复

使用道具 举报

qq8438529 | 2020-3-1 09:10:20 | 显示全部楼层
众号开发:7.向服务端发送

回复

使用道具 举报

kings | 2020-3-1 15:51:58 | 显示全部楼层
dsadsafgghgjhjtttt

回复

使用道具 举报

fendou1081 | 2020-3-5 10:55:15 | 显示全部楼层
6666666666666666666666666

回复

使用道具 举报

dashao | 2020-3-9 23:58:22 | 显示全部楼层
66666666666666666666

回复

使用道具 举报

jianxiaishen | 2020-3-20 22:33:00 | 显示全部楼层

回复

使用道具 举报

本版积分规则