请选择 进入手机版 | 继续访问电脑版

[视频教程] 传奇微信公众号开发:2.网关对接,TOKEN算法。

[复制链接]
查看1026 | 回复27 | 2020-2-13 11:07:53 | 显示全部楼层 |阅读模式
易语言开发传奇微信公众号.第二课-服务器和网关对接,TOKEN验证及算法,微信公众号传奇网关

易语言开发微信传奇网关教程

易语言开发微信传奇网关教程
易语言开发微信传奇网关教程

-易语言TOKEN源码如下:
.子程序 TOKEN验证
.参数 GET数据, 文本型
.参数 当前客户, 文本型
.局部变量 字符验证, 文本型
.局部变量 GET分割, 文本型, , "0"
.局部变量 数组重新排序, 文本型, , "0"
.局部变量 验证码, 文本型
.局部变量 数据加密, 类_数据操作
.局部变量 数据对比, 文本型

字符验证 = 子文本替换 (GET数据, “signature=”, “”, , , 真)
字符验证 = 子文本替换 (字符验证, “echostr=”, “”, , , 真)
字符验证 = 子文本替换 (字符验证, “timestamp=”, “”, , , 真)
字符验证 = 子文本替换 (字符验证, “nonce=”, “”, , , 真)
.如果真 (寻找文本 (字符验证, “&”, , 假) = -1)
    日志输出 (“TOKEN验证失败..”)
    返回 ()
.如果真结束
GET分割 = 分割文本 (字符验证, “&”, )
加入成员 (数组重新排序, GET分割 [3])
加入成员 (数组重新排序, GET分割 [4])
加入成员 (数组重新排序, _启动窗口.编辑框_微信接口_TOKEN.内容)
数组_排序 (数组重新排序, , )
验证码 = 数组重新排序 [1] + 数组重新排序 [2] + 数组重新排序 [3]
数据对比 = 数据加密.hex_sha1 (到字节集 (验证码))
.如果真 (GET分割 [1] = 数据对比)
    日志输出 (“TOKEN验证成功...”)
    服务器返回数据 (当前客户, #wx_协议头 + 时间_转为GMT格式 (取现行时间 ()) + #换行符 + #换行符 + GET分割 [2])
    返回 ()
.如果真结束
日志输出 (“TOKEN验证失败...”)
服务器返回数据 (当前客户, GET分割 [1])

第二课-服务器和网关对接,TOKEN验证及算法。
第三课-用户关注触发及保存用户信息到数据库。
更多详情请下载视频教程和源码附件工具。源码附件200论坛币出售,视频免费下载(回复后查看免费下载地址)

游客,如果您要查看本帖隐藏内容请回复


第二课源码.zip

171.63 KB, 下载次数: 6

售价: 200 金钱  [记录]

源码需要配合精益模板


传奇服务端版本附件下载说明 1、传奇GM论坛(WWW.DIYGM.COM)提供大量传奇版本服务端免费下载。
2、本站发布的传奇版本服务端,补丁素材,工具教程,登录器等全部均测试通过。
3、本站传奇相关资源附件以研究交流为目的,商业用途造成的后果与本站无关。
4、《传奇版本库》部分优质资源需要使用论坛会员下载或者金币下载。
获取金币方法:1、金币充值  2、免费获得传奇GM论坛基地金币。
回复

使用道具 举报

198256 | 2020-2-20 01:43:32 | 显示全部楼层
顶顶顶顶顶顶顶顶

回复

使用道具 举报

qqtz520 | 2020-2-28 16:01:52 | 显示全部楼层
pvfipvfipvfipvfipvfi

回复

使用道具 举报

11qw22as | 2020-2-29 03:15:08 | 显示全部楼层
我呵呵还真是活生生

回复

使用道具 举报

qq8438529 | 2020-3-1 08:57:31 | 显示全部楼层
传奇微信公众号开发:2.网关对接,TOKEN算法

回复

使用道具 举报

dashao | 2020-3-8 12:57:08 | 显示全部楼层
6666666666666666666666666

回复

使用道具 举报

dayi369 | 2020-3-16 13:34:29 | 显示全部楼层
回家干活干活很久

回复

使用道具 举报

jianxiaishen | 2020-3-17 23:48:41 | 显示全部楼层
卡卡都有啥东西呢

回复

使用道具 举报

6556277 | 2020-3-18 23:33:43 | 显示全部楼层
传奇微信公众号开发:1.安装和公众号基本介绍 [修改]

回复

使用道具 举报

11311aa | 2020-3-26 18:03:18 | 显示全部楼层
支持楼主,楼主给力

回复

使用道具 举报

本版积分规则